A couple of things that look wrong:
Ln 19 - The compiler is expecting matrix to be a type, but it's not declared anywhere. From your comment, this is supposed to be your ctor. Change it to:
I'm not sure I follow what you're trying to do with the  here.
Ln 21/23/25 - Again, you're using matrix instead of matrixType.
Ln 60 - There's an end to a C-style comment (i.e. */) that isn't matched with a starting /*; delete it.
Ln 71 - Need to add matrixType:: before getSize since it's a member function.
Fixing these should help clear up any remaining warnings and errors.
Thanks! I, unfortunately, don't have my compiler on hand at the moment since I'm at work, but I fixed these in notepad and will check them when I get home.
My naming convention was flawed initially as I called matrixType just matrix and it sounded more like a variable than a class. When I changed it I missed changing a few of them throughout the program.
The purpose behind matrix was that I was trying to declare the constructor for matrixType, but was having a severe brainfart when it came to doing so with 2 dimensional arrays.
I set the default constructor for matrixType to://Constructor
row = 0;
col = 0;
Which I think is correct, since row and col were delcared as private ints the constructor will initialize them to 0 and use them as the values for the matrix. Then when the setSize method is called with the corresponding matrix passed as a parameter it will then change row and col to the user-specified sizes. Right?
If you still have errors you can't fix, post the compiler errors along with the source code!
Yeah, I will if I run into problems I can't fix on my own. Didn't have the compiler on this computer so I'm just adjusting the code in notepad.